# Define environment variables ... LANG=en_GB.UTF-8 PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/games:/usr/local/bin:/usr/local/sbin SHELL=/usr/local/bin/bash # Ensure user/group/permissions are correct for personal/shared folders ... 0 0 * * * /usr/bin/find /mnt/data/user2/ ! -user user2 -exec chown user2 {} \; 0 0 * * * /usr/bin/find /mnt/data/user2/ ! -group staff -exec chgrp staff {} \; 0 0 * * * /usr/bin/find /mnt/data/user2/ -type f ! -perm 600 -exec chmod 600 {} \; 0 0 * * * /usr/bin/find /mnt/data/user2/ -depth +0 -type d ! -perm 700 -exec chmod 700 {} \; 0 0 * * * /usr/bin/find /mnt/data/user3/ ! -user user3 -exec chown user3 {} \; 0 0 * * * /usr/bin/find /mnt/data/user3/ ! -group staff -exec chgrp staff {} \; 0 0 * * * /usr/bin/find /mnt/data/user3/ -type f ! -perm 600 -exec chmod 600 {} \; 0 0 * * * /usr/bin/find /mnt/data/user3/ -depth +0 -type d ! -perm 700 -exec chmod 700 {} \; 0 0 * * * /usr/bin/find /mnt/data/user4/ ! -user user4 -exec chown user4 {} \; 0 0 * * * /usr/bin/find /mnt/data/user4/ ! -group staff -exec chgrp staff {} \; 0 0 * * * /usr/bin/find /mnt/data/user4/ -type f ! -perm 644 -exec chmod 644 {} \; 0 0 * * * /usr/bin/find /mnt/data/user4/ -depth +0 -type d ! -perm 755 -exec chmod 755 {} \; # Fetch updates for FreeBSD and Ports then clean the ports tree ... 0 0 * * * /usr/sbin/freebsd-update cron > /dev/null 0 0 * * * /usr/sbin/portsnap cron update > /dev/null 0 2 * * * /usr/local/sbin/portmaster -y --clean-distfiles > /dev/null 2 2 * * * /usr/local/sbin/portmaster -y --clean-packages > /dev/null 4 2 * * * /usr/local/sbin/portmaster --check-depends # Provide ZFS usage statistics ... 0 0 * * * /sbin/zfs list -o name,used,avail,compressratio -r pool1/home > /home/USAGE.txt 0 0 * * * /sbin/zfs list -o name,used,avail,compressratio -r pool1/mnt/data > /mnt/data/USAGE.txt 0 0 * * * /sbin/zfs list -o name,used,avail,compressratio -r pool1/mnt/timecapsule > /mnt/timecapsule/USAGE.txt # Scrub ZFS ... 0 0 * * 1 /sbin/zpool scrub pool1 # Create ZFS snapshots ... 0 0 * * 1-6 /usr/local/sbin/zfs-auto-snapshot daily 6 0 0 * * 0 /usr/local/sbin/zfs-auto-snapshot weekly 5